Website Performance Degradation

Incident Report for Brandeis University

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 18:01 EDT

Update

ITS continues to monitor website performance following optimizations to improve reliability. Services remain stable, but some users may occasionally encounter intermittent access issues or extra verification steps. We appreciate your patience and will provide updates as needed.
Posted Jun 22, 2026 - 12:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2026 - 22:36 EDT

Investigating

ITS is aware of reports of intermittent website issues and is actively investigating. Some users may experience degraded performance or temporary problems while we work to resolve the issue. Thank you for your patience.
Posted Jun 20, 2026 - 09:07 EDT
This incident affected: Brandeis Websites.