Access Issues for Some Workday Mobile Application Users

Incident Report for Brandeis University

Resolved

Workday has resolved the issue where users were unable to access Workday through the Workday Mobile App on both iPhone and Android. If anyone in the community continues to have issues, please submit a ticket at the following link:

https://brandeis.teamdynamix.com/TDClient/171/Portal/Requests/ServiceOffering/3699/Request-General-Help-with-Workday/Request
Posted Jun 22, 2026 - 12:38 EDT

Monitoring

A fix has been released by Workday for impacted Android users. Android users will need to ensure they have updated the Workday app to the latest version (2026.05.2.35034).

Workday has a scheduled updated for Friday 6/12/2026 to address the issues with iOS devices.

ITS will continue to work with the vendor to ensure a resolution to the access issue with the Workday Mobile Application.
Posted Jun 08, 2026 - 10:14 EDT

Update

Workday continues to be aware that some users are unable to access the platform through the Workday Mobile Application. WOrkday has specified that the next expected status update to resolve this issue will occur on Fri, 06/05/2026.

If anyone in our community is unable to log into or access features of the Workday Mobile App during this time, please log into Workday through a laptop or desktop computer.
Posted Jun 03, 2026 - 13:16 EDT

Identified

Workday is aware that some users are unable to access Workday through the Workday Mobile Application. Users are either unable to proceed past the Trusted Devices screen, or are presented with a loading screen and the Home page does not load. Their Development Team is currently working on a fix and will provide an update once the fix delivery date is determined.
Posted Jun 02, 2026 - 12:21 EDT
This incident affected: Workday (Workday ERP Platform).