Email Delivery Issues

Incident Report for Brandeis University

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 17:56 EDT

Monitoring

Proofpoint has resolved the issue affecting email delivery. Email delivery has returned to normal.

We will continue to monitor the service.
Posted Aug 14, 2026 - 13:43 EDT

Identified

Proofpoint, our email security provider, is currently experiencing an issue that is slowing email delivery. Proofpoint has identified the issue and is working to resolve it.

We will provide an update when more information is available.
Posted Aug 14, 2026 - 11:42 EDT
This incident affected: Google Workspace & Email Services (Google Apps Gmail, Email delivery (sending/receiving)).